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 PRODUCT NOTICE 
 

Notice of Potential Product Concern 

Rockwell Automation issues a Product Notice when it identifies a product(s) anomaly that may cause commercial or customer 
satisfaction concerns. 

 
 

AADvance Workbench Versions 1.x and 2.x 
Compiler Verification Tool Warnings 

 
Reference:  2020-08-001 
 

Date:  August 2020 
 
 
 

This Product Notice informs you of a potential anomaly that exists with AADvance® Workbench 1.x and 2.x.  The 
Compiler Verification Tool (CVT) generates warnings if a mismatch is found between the generated application and 
the original.  If the mismatches are not resolved and the project is subsequently recompiled, the warnings are not 
reported. 

 
 

 

– Product Identification – 
 
The affected product is AADvance Workbench, versions 1.x and 2.x. 

 
– Description – 

 
An anomaly exists with AADvance Workbench 1.x and 2.x.  The Compiler Verification Tool (CVT) generates warnings 

if a mismatch is found between the generated application and the original.  If the mismatches are not resolved and 
the project is subsequently recompiled, the warnings are not reported. 
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– Temporary Workarounds – 
 
Workarounds for this anomaly have been documented in the following two Rockwell Automation Knowledgebase 
articles: 

 

• BF25438 - https://rockwellautomation.custhelp.com/app/answers/answer_view/a_id/1126103 

• BF25455 - https://rockwellautomation.custhelp.com/app/answers/answer_view/a_id/1126175 
 
Copies of these articles have been attached as Appendix B and Appendix C to this notification.  A Rockwell 
Automation TechConnect contract is required to access the Knowledgebase articles directly. 

 
– Correction – 

 
Correction requires updating to SISW 1.1 or later.  Rockwell Automation is currently working on this release and is 

expected to have SISW 1.1 available for download and installation on or around the end of calendar 2020.  If you’d 
like to receive an email notification when SISW 1.1 is available, use the link provided at the end of the 
Knowledgebase article for this Product Notice. 
 

Rockwell Automation will make this release available for at least 18 months following its publication to the Rockwell 
Automation Product Compatibility and Download Center (PCDC). 
 

– Requested Customer Action – 
 
Rockwell Automation requests you take the following actions: 

 

• Check if you have a product affected by this Product Notice.  Refer to the Product Identification and 
Description sections of this document for product identification assistance. 

• Customers under support contract are automatically eligible for software updates.  Customers not under a 
support contract should contact Rockwell Automation for further instructions. 

• If you need additional assistance, please contact Rockwell Automation Technical Support.  See Appendix A 

for local telephone numbers. Customers without TechConnect℠ support contracts should reference this 

Product Notice when calling. 

• Customers with TechConnect support contracts may be able to chat online with support representatives. 
Reference this Product Notice when connected to a support engineer. 

  

The most current version of this Product Notice is posted on the Rockwell Automation 
Support Center, http://www.rockwellautomation.com/knowledgebase, as ID number 

PN1524 / 1127371.  Additional languages may also be available at the end of this article 
attached as downloadable PDF documents. 

 
 
If this Product Notice does not affect you because you do not have the products any longer, or if you are a Distributor, 

Rockwell Automation asks that you forward a copy of this notice, with any identifying documentation, immediately to 
the person or company that now has the product. We also ask that you contact Rockwell Automation Technical 
Support and provide the location of the affected units. 
 

https://rockwellautomation.custhelp.com/app/answers/answer_view/a_id/1126103
https://rockwellautomation.custhelp.com/app/answers/answer_view/a_id/1126175
https://rockwellautomation.custhelp.com/app/chat/chat_launch
http://www.rockwellautomation/knowledgebase
http://www.rockwellautomation.com/knowledgebase
https://rockwellautomation.custhelp.com/app/answers/answer_view/a_id/1127371
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We appreciate your immediate cooperation. If you have any questions, please contact us. 
 
Sincerely, 
 

ROCKWELL AUTOMATION 
 
 
You can register for Automatic Product Safety Advisories and Product Notices from Rockwell Automation by email. 

Go to the Support web page at http://www.rockwellautomation.com/support and click the Search Knowledgebase – 
Get Answers link.  Sign in with your TechConnect Account or free Rockwell Automation Member Account and you 
can subscribe to important product updates, including Product Safety Advisories and Product Notices. 
 
Trademarks not belonging to Rockwell Automation are property of their respective companies. 

 

 

http://support.rockwellautomation.com_/
http://www.rockwellautomation.com/support
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Appendix A 
Regional Technical Support Information 

 
The following list can help you to contact the correct technical support center for your location. If your country is not listed, you 
can find a customer support number for your location by going to the Rockwell Automation Knowledgebase as 
https://rockwellautomation.custhelp.com.  Click on Contact Us → Phone, and then enter your location information.  If you have 
a TechConnect℠ support contract, please use the telephone number supplied to you with the contract. 

 

Region / Country Phone Number 
( ) International Code  

Region / Country Phone Number 
( ) International Code 

Asia/Pacific    Europe   

Australia 1 800 762 593  Austria  (49) 211 41553 664 

China 400 620 6620  Belgium (32) 2 716 8411 

Hong Kong +852 2887 4666  Czech Republic  (420) 28401 5911 

India 1 800 2000 121  Denmark  (45) 43 466 006 

Japan 03 3206 2785  Finland (358) 958 447 419 

Korea (82) 2 2188 4400  France  (33) 825303132 

Malaysia 1 800 80 4851  Germany  (49) 211 41553 664 

New Zealand 0800 27 27 25  Hungary  (420) 28401 5911 

Taiwan 080 902 0908  Ireland  (44) 01908 635245 

Thailand (66) 2936 1500  Italy (Brescia, Milano e Padova) (39) 199 11 99 00 

Caribbean    
Italy (Bologna,Firenze,Napoli, 

Roma e Torino) (39) 199 11 99 22 

All Countries (English) (1) 440 646 3223  Morocco (33) 825303132 

All Countries (Español) (1) 440 646 3650  Netherlands (31) 10 266 55 80 

Central America    Poland  (48) 22 32 60 707 

Argentina 800.666.0320  Portugal (1) 440 646 3223 

Belize (1) 440 646 3650  Slovakia  (420) 284015911 

Bolivia (54) 800 10 0632  Spain  (34) 902 30 93 30 

Brazil (55) 11 5189 9500  Sweden  (46) 46 19 93 91 

Chile 800.53.0012  Switzerland  (German) (41) 0844 84 84 11 

Colombia 01.800.700.2107  Switzerland  (French) (41) 0844 84 84 12 

Costa Rica 0800.013.1215  Switzerland  (Italian) (41) 0844 84 84 13 

Ecuador 58.212.949.0611  United Kingdom  (44) 01908 635245 

El Salvador (52) 55 5246 2010  North America    

Guatemala 1.800.288.0108  Canada (1) 440-646-3223 

Honduras (52) 55 5246 2010  United States (1) 440-646-3223 

Mexico 001.888.365.8677    

Nicaragua (52) 55 5246 2010    

Panama 001.800.203.3475    

Paraguay (54) 11 5554 4000    

Peru 0800.535.36    

Suriname (1) 440 646 3650    

Uruguay (54) 11 5554 4000    

Venezuela 800.1.00.3062    

  

https://rockwellautomation.custhelp.com/
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Appendix B 
Rockwell Automation Knowledgebase Article BF25435 

AADvance CVT warnings may not be reported for subsequent Build All operations 
 

Summary 
 

After a Build All operation that resulted in CVT warnings, subsequent Build All operations may not report the existing 
CVT warnings, unless the affected component has been modified between Build All operations or a complete rebuild 
has been triggered. 
 

Original Build: 
 

 
 
Subsequent Build: 
 

 
  
 

Environment 
 
All versions of AADvance Workbench 1.X and AADvance Workbench 2.X. Affects all safety-related applications that 
must have the Compiler Verification option enabled as per the AADvance controller Safety Manual. 

  
Cause 
 
The Build All is an incremental operation, it only rebuilds what is flagged internally as modified. The compiler does not 

keep track of previously reported CVT warnings. If the result of a Build All operation contains CVT warnings and no 
modifications are made to the application, subsequent Build All operations will not report the existing CVT warnings. 
  
Solution 
 

The following solutions can be implemented to ensure that all CVT warnings are reported during a Build All operation: 
 
Solution 1: Online Updates/Online Monitoring are not required: Clean All 
 

Doing a Clean All will force the compiler to check the entire application for CVT warnings. 
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Important Note: After a Clean All, it will not be possible to perform an Online Update or to Debug the application by 
doing online monitoring.  A full download will be required for all the controllers in the application (stopping the 
application from running temporarily). 
 

Warning: Do not do a Clean All on an application of a running system if you cannot do full download afterwards. 
 

• To do a Clean All in AADvance Workbench 1.X, go to Project > Clean Project/Library. 

• To do a Clean All in AADvance Workbench 2.X, go to Build > Clean All. 
 
Solution 2: Online Updates/Online Monitoring are required, and you are troubleshooting a POU with known CVT 

warnings: Non-functional edit to the POU. 
  
Making a non-functional edit to a POU forces the compiler to check the POU for CVT warnings. 
 

To make a non-functional edit to a POU, use one of the following: 
 

• Change the position of a variable box, a function, or a function block slightly; without affecting the execution order 
or causing connecting lines to overlap. 

 
Original logic: 
 

 
 
Non-functional change: 
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• Change the size of a variable box, a function, or a function block slightly. 
 
Original logic: 
 

 
 
Non-functional change: 
 

 
 
Solution 3: Online Updates/Online Monitoring are required, and you need to check the entire application for CVT 
warnings: Add a Global variable per controller. 
 

Adding a Global variable in a specific controller triggers a full compilation of the controller, forcing the compiler to 
check the controller for CVT warnings.  For a multi-controller application, a new Global variable is required in each 
controller to check the entire application for CVT warnings.  After the Build All operation is complete, the Global 
variable(s) can be deleted. Removing the Global variables will also trigger a full compilation.  

 
To add a Global variable in AADvance Workbench 1.X, go to the Dictionary under Project > Variables and create a 
temporary variable of any elementary Data Type and of Global Scope. 
 

 
 
 
To add a Global variable in AADvance Workbench 2.X, go to the Application View > Variables > Controller Variables 
and create a temporary variable of any elementary Data Type. 
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Appendix C 
Rockwell Automation Knowledgebase Article BF25455 

A problem occurred during processing of STF AADvance CVT warning 
 

Summary 
 
After a Build All operation the following CVT warning can be seen for all Programs, Functions and Function Blocks in 
the application: 

 
Warning, a problem occurred during processing of 

C:\USERS\USERNAME\DOCUMENTS\AADVANCE 

2.X\PROJECTS\<ProjectName>\<ProjectName>\<ProjectName>\<ConfigNam

e>\<ResourceName>\<POUName>.STF 

 
AADvance Workbench 2.X: 

 

 
 
AADvance Workbench 1.X: 
 

 
 
In addition to the warning, AADvance Workbench 1.X will display a blank stf2xml warning pop-up during the CVT 

Analysis for each Program, Function and Function Blocks in the application. 
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Environment 
 

• All versions of AADvance Workbench 1.X and AADvance Workbench 2.X. 
• Affects all safety-related applications that must have the Compiler Verification option enabled as per the 

AADvance controller Safety Manual. 
 
Cause 
The affected Resource is locked. 

 
In an AADvance Workbench 1.X application, a Resource can be locked when the project folder is copied with the 
AADvance Workbench 1.X open. The Resource appears to be in use by another user that cannot be accessed. 
There are multiple visual indications of a locked Resource: 

 

 
 

An AADvance Workbench 2.X application can have a locked Resource when the application has been imported from 
an AADvance Workbench 1.X application where the Resource was locked. 
 
Important Note: There are no visual indications for a locked Resource in AADvance Workbench 2.X. 

 
Solution 
 
Unlock the Resource in AADvance Workbench 1.X. 

 
To unlock a Resource in AADvance Workbench 1.X, click on the locked Resource to select it and then go 
to Tools > Unlock Resource used by User. 
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The unlocked Resource should look like this: 
 

 
 
To prevent importing a locked Resource into AADvance Workbench 2.X, verify that all the Resources are unlocked in 
the AADvance Workbench 1.X application before importing it. 

 
Important Note: It is not possible to unlock a Resource in AADvance Workbench 2.X. 
 


